Smart List Creation Experience Degraded
Incident Report for Intricately
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 21:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2020 - 17:20 PDT
Investigating
Our new Smart Lists creation page is missing welcome messaging and instructions for how to create your Smart List.

We are currently investigating this issue.
Posted Jun 15, 2020 - 12:52 PDT
This incident affected: intricately.com (Smart Lists).