Service Outage
Incident Report for Intricately
Resolved
This incident has been resolved.
Posted Nov 03, 2020 - 12:48 PST
Investigating
We are currently investigating this incident.
Posted Nov 03, 2020 - 11:39 PST
This incident affected: intricately.com (List Enrichment, Smart Lists, Login and Signup), Intricately API (Company API, Enrichment API, Data Snapshots API, Events API), Salesforce Connector (Enrichment), and Chrome Extension.