Unable to create new Smart Lists
Incident Report for Intricately
Resolved
Smart List operation is now back to normal.
Posted Jul 05, 2019 - 10:04 PDT
Investigating
We are currently investigating this issue.
Posted Jul 05, 2019 - 09:39 PDT
This incident affected: intricately.com (Smart Lists).